SCOM 2016 GW Approval Tool Error

Forum: Operations Manager4

Tagged: 

Viewing 3 posts - 1 through 3 (of 3 total)
  • #230796
    Profile photo of Mike
    Mike
    Participant

    I have 2 MS servers and 2 GW Servers.

    MS: ms101, ms201

    GW: gw101, gw201

    The Gateway server gw101 is connected to my SCOM enviroment with the ms101 as the primary ms. The server ms201 is the failover MS for the gw101

     

    Now i want to add the gw201 to my SCOM enviroment. ms201 should be the primary MS und ms101 the secondary/failover.

     

    On the first gw approval i had no error with the tool.

    But now when i try to do the same thing with the second gw server i get the error that the approval tool has stopped working.

     

    This is the Information i get:

    Unhandled Exception: System.TypeLoadException: Could not load type ‘SCTrace’ from assembly ‘Microsoft.EnterpriseManagement.Core, Version=7.0.5000.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35’.
    at Microsoft.EnterpriseManagement.DataAccessLayer.SqlConnectionHandler.Open(SqlConnection sqlConnection, RetryPolicy retryPolicy, DatabaseConnection databaseConnection)
    at Microsoft.EnterpriseManagement.DataAccessLayer.DatabaseConnection.Open()
    at Microsoft.EnterpriseManagement.DataAccessLayer.QueryRequest.Execute(SqlNotificationRequest sqlNotificationRequest)
    at Microsoft.EnterpriseManagement.DataAccessLayer.TypeSpaceDataCache.IsTypeCacheUpdateRequired(DatabaseConnection databaseConnection, DateTime& timeOfLastTypeChange, QueryResults& queryResults)
    at Microsoft.EnterpriseManagement.DataAccessLayer.TypeSpaceDataCache.GetData(DatabaseConnection databaseConnection)
    at Microsoft.EnterpriseManagement.DataAccessLayer.DatabaseConnection.GetQueryDefinition(String queryDefinitionName)
    at Microsoft.Mom.Setup.MomTopology.ManagementServerInsertion.ComputerExists(String principalName, DatabaseConnection databaseConnection)
    at GatewayInsertionTool.Program.Main(String[] args)

     

    (i am running the script on my ms201)

    The certificate is the same than on my ms101 just with the FQDN of ms201

    The connection between the Servers is working (Test-NetConnection in Powershell)

    The gw201 server has the same certificate as my gw101 just with the FQDN of gw201

    i copied both the config file and the approval tool into: C:\Program Files\Microsoft System Center 2016\Operations Manager\Setup

    I have edited the config file like this:

    <startup useLegacyV2RuntimeActivationPolicy=”true”>
    <supportedRuntime version=”v4.0″/>
    </startup>

     

    Event viewer:

    Application: Microsoft.EnterpriseManagement.GatewayApprovalTool.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.TypeLoadException
    at Microsoft.EnterpriseManagement.DataAccessLayer.SqlConnectionHandler.Open(System.Data.SqlClient.SqlConnection, Microsoft.EnterpriseManagement.DataAccessLayer.RetryPolicy, Microsoft.EnterpriseManagement.DataAccessLayer.DatabaseConnection)
    at Microsoft.EnterpriseManagement.DataAccessLayer.DatabaseConnection.Open()
    at Microsoft.EnterpriseManagement.DataAccessLayer.QueryRequest.Execute(System.Data.Sql.SqlNotificationRequest)
    at Microsoft.EnterpriseManagement.DataAccessLayer.TypeSpaceDataCache.IsTypeCacheUpdateRequired(Microsoft.EnterpriseManagement.DataAccessLayer.DatabaseConnection, System.DateTime ByRef, Microsoft.EnterpriseManagement.DataAccessLayer.QueryResults ByRef)
    at Microsoft.EnterpriseManagement.DataAccessLayer.TypeSpaceDataCache.GetData(Microsoft.EnterpriseManagement.DataAccessLayer.DatabaseConnection)
    at Microsoft.EnterpriseManagement.DataAccessLayer.DatabaseConnection.GetQueryDefinition(System.String)
    at Microsoft.Mom.Setup.MomTopology.ManagementServerInsertion.ComputerExists(System.String, Microsoft.EnterpriseManagement.DataAccessLayer.DatabaseConnection)
    at GatewayInsertionTool.Program.Main(System.String[])

    (Event ID 1026)

     

    and:

    Faulting application name: Microsoft.EnterpriseManagement.GatewayApprovalTool.exe, version: 7.2.11719.0, time stamp: 0x5798ac6d
    Faulting module name: KERNELBASE.dll, version: 10.0.14393.2189, time stamp: 0x5abdad60
    Exception code: 0xe0434352
    Fault offset: 0x0000000000033c58
    Faulting process id: 0x13b4
    Faulting application start time: 0x01d3fbe948a510f7
    Faulting application path: C:\Program Files\Microsoft System Center 2016\Operations Manager\Setup\Microsoft.EnterpriseManagement.GatewayApprovalTool.exe
    Faulting module path: C:\Windows\System32\KERNELBASE.dll
    Report Id: d6774246-a522-427d-97e2-42e6b49a56b7
    Faulting package full name:
    Faulting package-relative application ID:

    (Event ID: 1000)

    #230962
    Profile photo of Konstantin
    Konstantin
    Participant

    i copied both the config file and the approval tool into: C:\Program Files\Microsoft System Center 2016\Operations Manager\Setup

    Hi,
    please try to copy the ApprovalTool and config file to C:\Program Files\Microsoft System Center 2016\Operations Manager\Server.

    I had the same errors (SCOM 1801) with executing from /Setup folder but not from the /Server folder although that worked with SCOM 2012 R2.

    Regards,
    Konstantin

    #230964
    Profile photo of Mike
    Mike
    Participant

    Hey,

     

    Tried it out, seems to have worked now.

    Thanks for the help.

     

    Regards,

    Mike

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.