System Center CentralProblem discovering SSRS instance with underscore in the name (Native SSRS MP) – System Center Central http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/feed Wed, 20 Jun 2018 13:04:03 +0000 http://bbpress.org/?v=2.5.12-6148 en-US http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-222865 <![CDATA[Problem discovering SSRS instance with underscore in the name (Native SSRS MP)]]> http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-222865 Tue, 09 Sep 2014 12:33:18 +0000 ComputerBob Some of you may remember my post about the SQL 6.5.1.0 MP having trouble discovering SSRS on server when the machine name was lowercase.  That problem still exists, but I’ve dropped that in the hands of MS and moved on to using the SSRS MP (thank you Sergei for pointing me in the right direction).

However, I’ve discovered a new problem with this MP and the SSRS instance discoveries: Any instance that has an underscore in the name (Instance_Name) will fail to be discovered and generate a 6201 event in the OpsMan event log as well as an alert in the console.  The details will simply say “Invalid Namespace” and won’t detail why.

My colleague found an article about how in WMI any instance that has an underscore in the name also has a “5f” added to it.  This may be the cause of the problem, but I’m not positive.  This means that “Instance_Name” becomes “Instance_5fName” in WMI.

I have a ticket open with MS Premier support to investigate.  They are working to replicate the situation in their lab.  As I have new information I’ll post it here, but I have no idea how they’ll approach this as it seems that the %f addition is by design, so the discovery process has to be modified which means a change to the MP is necessary.  Will they hotfix it?  Or will we be forced to simply wait until the next release?  I have LOTS of instances not being discovered right now, so this is a major deal to me.

Has anyone else noticed this in their environments?  Were you able to work around it?

]]>
http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-222866 <![CDATA[Reply To: Problem discovering SSRS instance with underscore in the name (Native SSRS MP)]]> http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-222866 Tue, 09 Sep 2014 16:01:28 +0000 Sergei Jemeljanov (EU) same here, just discovered that my LYNC_RS instance is not discovered.

tomorrow i will  try to troubleshoot.

]]>
http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-222901 <![CDATA[Reply To: Problem discovering SSRS instance with underscore in the name (Native SSRS MP)]]> http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-222901 Thu, 11 Sep 2014 19:26:44 +0000 Shaun Collins Ditto. I had to reinstall the SSRS instance.

]]>
http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-222905 <![CDATA[Reply To: Problem discovering SSRS instance with underscore in the name (Native SSRS MP)]]> http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-222905 Thu, 11 Sep 2014 19:34:48 +0000 ComputerBob I received confirmation from the MS Technician this morning that he was able to replicate this in his lab and is submitting this as a bug to his team.  I’ll keep you all updated as I have updates.

Underscores are allowed in SSRS instance names, it’s in the documentation, so we shouldn’t have to reinstall SSRS just to be able to monitor it.

]]>
http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-223066 <![CDATA[Reply To: Problem discovering SSRS instance with underscore in the name (Native SSRS MP)]]> http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-223066 Mon, 22 Sep 2014 14:25:28 +0000 Mark Hello,

I am currently experiencing the same issue with instance names that include a “\”.

By chance, has Microsoft replied with a resolution for the problem?  Unfortunately, renaming or recreating instances is not an option.

Thanks!

]]>
http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-223068 <![CDATA[Reply To: Problem discovering SSRS instance with underscore in the name (Native SSRS MP)]]> http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-223068 Mon, 22 Sep 2014 16:46:51 +0000 ComputerBob According to this article, you cannot have instances with a backslash in the name.  An underscore is allowed, but a backslash is not.

Named instance

Choose this option to create a new named instance. Bear in mind the following when naming an instance of SQL Server:

  • Instance names are not case sensitive.

  • Instance names cannot contain the terms “Default,” “MSSQLServer,” or other reserved keywords. If a reserved keyword is used in an instance name, a Setup error will occur.

  • Instance names are limited to 16 characters.

  • The first character in the instance name must be a letter or an underscore (_). Acceptable letters are those defined by the Unicode Standard 2.0, including Latin characters a-z, A-Z, and letter characters from other languages.

  • Subsequent characters can be letters defined by the Unicode Standard 2.0, decimal numbers from Basic Latin or other national scripts, the dollar sign ($), or an underscore (_).

  • Embedded spaces or other special characters are not allowed in instance names; nor are the backslash (\), comma (,), colon (:), semi-colon (;), single quote (‘), ampersand (&), or at sign (@).

Microsoft is working to figure out how to get around the underscore issue.  Since they do say they support that character in the names, they should support it in the discovery and monitoring as well.

 

]]>
http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-223069 <![CDATA[Reply To: Problem discovering SSRS instance with underscore in the name (Native SSRS MP)]]> http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-223069 Mon, 22 Sep 2014 18:25:57 +0000 Mark Thank you for the information Bob!

I was mistaken this whole time.  The instance name that I am having issues with does indeed contain an “_” in the instance name.  I was focused on the wrong thing all together.

With that said, I am in the same boat that you are in.  I am interested to hear what they do to resolve this.

Please post what you hear back from them.

Side note:  Is that a V-Strom you’re riding in your avatar?

]]>
http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-223070 <![CDATA[Reply To: Problem discovering SSRS instance with underscore in the name (Native SSRS MP)]]> http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-223070 Mon, 22 Sep 2014 19:25:33 +0000 ComputerBob That’d be my 2005 BMW R1200GS.

I have a call scheduled with the MS Tech this afternoon and will post here after that call to update you all on any progress (if any) they are making.

]]>
http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-223071 <![CDATA[Reply To: Problem discovering SSRS instance with underscore in the name (Native SSRS MP)]]> http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-223071 Mon, 22 Sep 2014 19:38:05 +0000 Mark Thanks Bob!

I’ll keep an eye out for your post.

Nice bike man!  I love the BMW.  I own a 2012 Suzuki DL 1000, it’s a great bike.  But, not the R1200.  You have good taste!

Play on player!

]]>
http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-223072 <![CDATA[Reply To: Problem discovering SSRS instance with underscore in the name (Native SSRS MP)]]> http://www.systemcentercentral.com/forums-archive/topic/problem-discovering-ssrs-instance-with-underscore-in-the-name-native-ssrs-mp/#post-223072 Mon, 22 Sep 2014 21:39:58 +0000 ComputerBob I just got off the phone with the MS Tech.  We spent some time talking about the differences in the SSRS MP’s discovery process and the base SQL MP’s discovery process.  The base MP uses a VB script and even though the SSRS discoveries are disabled by default and only monitor whether the service is running or not, at least they do discover every instance.  The SSRS Native MP uses a dll discovery process and fails miserably when it comes to the underscore.  It also logs very cryptic messages in the event logs anytime something fails to discover properly.  At least with the VB script, you could run it manually and see where it was failing.  The dll process is impossible to do anything with (as far as I know) and leaves us having to call MS every time we get one of those cryptic errors.

I showed him that the VB script from the 6.5.1.0 version of the base SQL MP discovers all the instances just fine, but the SSRS MP doesn’t.  Even on the same server.  Apparently, they included something in the VB script to account for the ‘5f’ in the wmi call, but didn’t do that in the dll they built for the SSRS MP.

He shared his lab’s desktop and we created an instance on his SQL 2012 server and we imported the SSRS MP for 2012.  Same issue exists there also.  We didn’t test 2014, but I’m betting it’s also there.

So, here’s where we stand right now: You can enable the SSRS instance discovery for the base SQL MP and you’ll know where all the instances are.  You’ll also get monitoring for the SSRS service.  You won’t get any of the bells and whistles that come with the SSRS MP, but at least you’ll know where all the instances are at.

Then you can compare that list to the list in the SSRS MP’s Instance view and see which ones are already being monitored by the SSRS MP and disable the discovery on those so you’re not duplicating the monitoring.

This should get you by with minimal monitoring until MS comes out with the fix to this issue.   This will only work for 2008 and 2012 since I don’t think there’s a discovery at all for SSRS 2014 in the base 2014 MP.

When will they publish a fix?  I have no idea.  I do know that they’ll put more focus on it if they can “quantify a larger impact”.  What does that mean?  Right now, they are assessing the impact by how much it’s impacting me and my environment.  Nobody else has called them about the problem, so they don’t have any documented instances of it affecting any other customers.  <hint> <hint>

]]>