MS High-CPU caused by wmiprvse.exe process

Forum: Operations Manager4
Viewing 8 posts - 1 through 8 (of 8 total)
  • #91244
    Profile photo of
    Anonymous

    I have a Management Server (non-RMS) on VMware, Windows 2003R2 SP2, dual cpu, 2GB RAM, with 450 agents assigned.  We’re on SCOM2007 R2 CU5. There was a period of time that CPU was at 100% and found that wmiprvse.exe was causing this.  During that time the MS saw eventid 20022/20020 Health Service is not Heartbeating on all agents resulting in a bunch of false alerts.  I rebooted the server, but still saw wmiprvse.exe causing high cpu for another hour or so.  This happens on small occasions.  Is there a remedy for this?

    #91245
    Profile photo of
    Anonymous
    #91248
    Profile photo of
    Anonymous

    Thanks for the lead. I downloaded the kb937882, but when I ran the fix, it gave me a notification that the server is not a SMS server and stopped. My issue of 100% cpu continues. Any other possible fixes?

    #91249
    Profile photo of
    Anonymous
    #230115
    Profile photo of hunny
    hunny
    Participant

    For me, it was the Windows Management Instrument Services that had to be restarted from the services.msc. Since restart and reboot, the wmi provider host usage has gone down to less then 10%. https://appuals.com/how-to-fix-wmiprvse-exe-high-cpu-usage-on-windows-10/

    #230120
    Profile photo of hunny
    hunny
    Participant

    For me, it was the Windows Management Instrument Services that had to be restarted from the services.msc. Since restart and reboot, the wmi provider host usage has gone down to less then 10%.

    #230582
    Profile photo of Kaushal
    Kaushal
    Participant

    Users can download and install the Reimage Plus software. This software can be used to scan, repair and restore all the corrupt and missing files from  The users can check whether the WMI Provider Host has high CPU usage drops. If not then they can try other alternatives.

    Reference Links:

    https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/wmi-provider-host-high-cpu-usage-and-laptop/44cb3953-a883-404a-a94f-ee4f363d3a4b?page=2&auth=1

    https://www.techwhoop.com/wmi-provider-host-high-cpu-usage/

    #231037
    Profile photo of sapnasingh
    sapnasingh
    Participant

    wmiprvse.exe handles much application that’s why sometimes we have to face error but you can solve this by restarting WMI provider host service and for this you need to follow these steps:

    1. At first, type services.msc in the run window.
    2. Then, find Windows Management Instrument and restart it.
    3. Now, open command prompt.
    4. Type these commands

    cnet stop iphlpsvc

    net stop wscsvc

    net stop Winmgmt

    net start Winmgmt

    net start wscsvc

    net start

    Now, restart your PC and you will see that no error is there now.

    source: https://www.surfwindows.com/wmi-provider-host-high-cpu-usage/

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.