HP Device Monitor Service was unable to discover the device

Forum: Operations Manager4
Viewing 11 posts - 1 through 11 (of 11 total)
  • #95253
    Profile photo of sajmeister
    sajmeister
    Member

    Hi,

    We are using SCOM 2007 R2 and have recently imported the HP SCOM Management Packs.  SCOM has successfully discovered HP Proliant servers but am having great difficulty in getting BladeCenter enclosures to be discovered.  We are using HP BladeCenter MP v2.0.0.

    I input the relevant details in Device Monitor Console and then get below in HP Device Monitor event log :-

    Log Name:      HP Device Monitor
    Source:        HP Device Monitor Core
    Date:          21/08/2012 09:52:49
    Event ID:      440
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      xxxxxxxxxxxxx.com
    Description:
    The HP Device Monitor Service was unable to discover the device.  Please check the connection and configuration for the device and try to discover the device again.
    Could not discover or identify xxx.xxx.xxx.xxx.  Ensure the device is up and connected to the network.  Ensure the credentials are correct by verifying the community string for SNMP managed devices.  Ensure the Insight Management Agents are currently running on in-band server devices.  Ensure the Agentless Management is configured properly in the iLO Management Engine for out-of-band server devices.

    HTTPS/SNMP have been successfully tested between SCOM server and BladeCenter chassis, chassis is sending traps to SCOM server as verified that using snmputil.  Also tried setting the 3 monitoring profiles related with this MP to use Local System Account and it still doesn’t work. Local System account also has permissions to read/write to the HP Device Monitor directory structure.

    OA firmware is v3.0

    Any help much appreciated.

    #95254
    Profile photo of KMV
    KMV
    Member
    #95256
    Profile photo of sajmeister
    sajmeister
    Member

    SNMP config is ok.  Good article by the way.

    Let me give you abit of a background to our SCOM environment.

     

    We have a 2 node active-passive clustered SCOM 2007 R2 RMS server and 2 management servers all in one Datacenter.

    We have 2 additional management servers in a second datacenter in a different location.

    We have 2 further management servers in a third datacenter also in a different location.

     

    I think the idea behind this was to enable those management servers located in one datacenter to monitor BladeCenter Chassis that are also part of the same datacenter.

     

    All of the above management servers have the HP Device Monitor Service and HP Common Services running.  I could not see that service on our virtual RMS server.  Then again, it doesn’t really need to be on there, right ?

     

    Anyway, the RMS server has the HP Device Monitor Console installed and when I launch it, it only has green ticks next to the 2 management servers that are in the same datacenter as the RMS.  The other management servers in other datacenters are showing up within the console as ‘HP Device Monitor Connection Error’ and showing red. 

    Why is this ? Is it down to a port being blocked ?

     

    If I logon to the other management servers and launch the console they show up fine there.  I tried to do the discovery on one of these management servers of a BladeCenter chassis that is in the same datacenter as the management server and it fails as per event ID 440. 

     

    Your help much appreciated.

    #95268

    Hi,

    As I am the author of this article I feel obligated to help you 🙂 . Here is what is stated in the management pack documentation:

    The HP BladeSystem Enclosure Monitor Manager and Monitor Service work with WinHTTP networking infrastructure.

    So I guess you have to check if ports 80 and 443 are open from where your HP Device Monitor Console is located to the servers that have Hp Enclosure Monitor Service is installed.

    Hope this will help you.

    #95276

    what is the exact problem you cannot connect from HP Device Monitor console to HP Device monitor service?

    Or you cannot connect from HP Device Monitor console to Blade Enclosure?

    #95294

    It is strange because the error that you have is generated when you try to add Onboard Administrator or ESX/linux server to monitoring in HP Device Monitor Console:

    http://cloudadministrator.files.wordpress.com/2012/08/image5.png

    http://cloudadministrator.files.wordpress.com/2012/08/image6.png

    In the screenshots you can see HP Device Monitor Console. When you start the console from you RMS server under Device Monitor Connections you should have connections to localhost (RMS server) and another two connections to your other two management Servers.

    The console is just for managing and the console only connects to servers where you have HP Device Monitor Service installed and running. When you connect to such service via the console you can configure connections to Enclosures and ESX/linux servers for that service.

    Your account also should be administrator on the servers where you connect the console.

    Can you post screenshots of how your console looks and how you try to connect to the other HP Device monitor services on your MS servers because as you describe it you are using Add Onboard Administrator Action to connect to HP Device Monitor Service?

    #96027
    Profile photo of Deepali
    Deepali
    Member

    Hi ,

    Is this issue resolved. Are you able to discover OA in SCOM now.

    Regards,

    #228334
    Profile photo of Ivan Mokrotovarov
    Ivan Mokrotovarov
    Participant

    Hello. Faced with the same problem. When you try to add the OA, we get the error 440. snmpwalk data gets. xmlview just opened with the machine on which the service is installed.

    before the advent of the error 440, an error occurs 210 –
    HTTP request error.
    Web Exception status = ProtocolError occurred for http PUSH request: http status = NotFound.

     

    Attachments:
    You must be logged in to view attached files.
    #230724
    Profile photo of sushil
    sushil
    Participant

    Even I am getting same error. Any support on this would be really appreciated.

    #230725
    Profile photo of sushil
    sushil
    Participant

    Even I am getting same error. Any support on this would be really appreciated.

    Attached the error message. My SCOM environment is SCOM 2012 R2 & we have installed DMC & DMS in other box, that have only SCOM agent.

    Attachments:
    You must be logged in to view attached files.
    #230781
    Profile photo of vpotapov
    vpotapov
    Participant

    I am getting same error too. Any support on this would be really appreciated. For all of us)

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.